Flowable IDM user authentication issue

Hi,

I am new to Flowable, so I am hoping my issue is simple and has been seen before.
I setup Flowable with Postgres as the DB, which on it’s own seems to work fine.
However, after I deploy IDM and attempt to connect to the flowable-idm application, I am not able to login with the default username / password, it gives me an ‘Invalid credentials’ message.
The Tomcat logs show the same message, and only that message, so that does not help me either.

I am hoping it is a simple setup issue, but am not sure.
Has anybody seen this before, to the point where you can help me into the correct direction ?

Thanks.

1 Like

Hi

I faced similar issue during first time configuration.

Please ensure that you configure the database credentials on all of the below properties:
(Stop the server and perform changes to the below properties)

  1. webapps\flowable-admin\WEB-INF\classes\META-INF\flowable-ui-app\flowable-ui-app.properties
  2. webapps\flowable-idm\WEB-INF\classes\META-INF\flowable-ui-app\flowable-ui-app.properties
  3. webapps\flowable-modeler\WEB-INF\classes\META-INF\flowable-ui-app\flowable-ui-app.properties
  4. webapps\flowable-rest\WEB-INF\classes\db.properties
  5. webapps\flowable-task\WEB-INF\classes\META-INF\flowable-ui-app\flowable-ui-app.properties
    (start the server)

Sorry if this post is not helpful

Thanks

2 Likes

Hi rprakash88,

I did not deploy the admin, modeler and task applications just yet, just so I could try and get IDM to work. Initially I did try and deploy all applications, which is when I ran into the issue with authentication, so I installed the server all over again, but with just rest and IDM deployed.
I checked both files indicated and the DB credentials / properties are correct.

Unless I have to deploy any of the other applications to make this work, I would like to wait with that, until I have the authentication issue resolved.

Is there a way to setup some sort of Debug logging ? If so, that may help me out. Currently I just do not see any info in the logs that is helpful to resolve this …

1 Like

Hi bpmman64,
tested with fresh & default setup,
managed to login flowable-idm with default credential admin/test
anything else I miss out?

Hi Faizal,

I changed my environment to use the H2 / In Memory database, and then everything works fine, however, when I use Postgres, I end up with the problems I described before.
That to me means I either have a connectivity issue (however everything starts up just fine), or there is a driver issue / bug somewhere… ?

Sorry bpmman64,
I just tries with postgres, but not able to reproduce the error

  1. Is required database and table by idm has been created?
  2. installed database driver?
  3. any error during startup?

Hi Faizal,

yes, the ID_USER table is there in Postgres and the driver I am using is the one recommended by Flowable.
I have not seen any errors during startup at all, I specifically have been watching for that.

I have been doing some more research, and changed the log level for IDM to DEBUG.

When I try to login to IDM, it shows the following message :

Could not find key ‘ldap enabled’ in any property resource.

That would point to the system wanting to use LDAP for user authentication, however, I checked the flowable-ui-app.properties file, and ldap.enabled=true is still commented out (it still has the ‘#’ at the start of the line).
That is the case for all properties files, so I am not sure why it shows this message ?

The next message clearly shows the rollback of the JDBC transaction as well …

Why would Flowable IDM try to use LDAP, if that has not been enabled ?

More research done :

I switched back to the H2 database, and the ldap check seems to be normal, it does so with H2 as the database as well, so that is not an issue. However, I do not see a rollback when using H2, and like I said, the authentication is working with H2 as the DB.

I checked my Postgres DB, and it has all ‘engine’ and ‘history’ tables.
I also know for sure the username and password are correct, given that when I change either, I get errors during startup.
The user has ‘all’ privileges on the DB used as well, so that cannot be a problem either.
I checked the DB logs, but there are no errors (or any messages for that matter) at the time of the authentication attempt.

I am completely at a loss here, as to why this is not working.

The only difference between the H2 and Postgres setup is the db.properties file in the ‘rest’ folder and the ‘flowable-ui-app.properties’ in the other application folders …no other changes have been made …

Problem solved. It turned out to be an issue with the database itself. The logs did not show any errors at all, which makes it difficult to find of course …

do you mind to share what’s the issue with the database?

Hi Faizal,

the issue was that one of the ‘optional’ applications was pointing to the default ‘flowable’ database, instead of it’s own database. For some reason that caused an issue and nothing seemed to work right. For now I have multiple databases (flowable, admin, idm etc.) and that works.

Thanks that helped. Default username : admin, Password: test