Disable Auto creation of DB Tables


We know that tables automatically creates on first run of flowable applications,
but, i need to disable this feature while deploying application into Production Environment.
may i know any configuration value need to update for disable this auto creation of tables?


I believe the information you need can be found in the doc:

Hi dbmalkovsky,

thanks for quick reply, i got the db scripts available for executing manually, but never find to STOP creating tables automatically, can you please suggest


Have you tried from https://www.flowable.org/docs/userguide/index.html#databaseConfiguration

databaseSchemaUpdate: sets the strategy to handle the database schema on process engine boot and shutdown.

  • false (default): Checks the version of the DB schema against the library when the process engine is being created and throws an exception if the versions don’t match.

  • true: Upon building the process engine, a check is performed and an update of the schema is performed if it is necessary. If the schema doesn’t exist, it is created.

  • create-drop: Creates the schema when the process engine is being created and drops the schema when the process engine is being closed.

After investigation, solution for this is by providing value in flowable.cfg.xml file as,

property name=“databaseSchemaUpdate” value="none"


Hey, Could you tell me the location of flowable.cfg.xml file in flowable. It seems to have many copies of the same file . We are using docker image of rest, idm, task, rest etc. and want to disable migration. Your solution seems to fit the bill perfectly but I am not able to locate correct flowable.cfg.xml file.
You help would be appreciated. Thanks in advance.


I think that in your case you should pass docker variable:
flowable.databaseSchemaUpdate=false (or FLOWABLE_DATABASE_SCHEMA_UPDATE=false )

flowable.databaseSchemaUpdate=none (or FLOWABLE_DATABASE_SCHEMA_UPDATE=none )
is better :slight_smile: cause “false” would run schema check

Hey rgorzkowski,

Thanks for the rely. I tested this and it work. Previously I was setting environment variable without flowable.prefix and that was the reason it wasn’t getting picked up.