Disable Flowable Table auto create and manually run the scripts

Hi Guys,

We have requirement for our processEngine which is to seperate out the Flowable schema script files and manually run the scripts. If any Flowable upgrade happens, then we should manually run those upgrade sql files and the Flowable should not upgrade the tables using liquibase. So I have tried to include config.setDatabaseSchemaUpdate(ProcessEngineConfiguration.DB_SCHEMA_UPDATE_FALSE); in processEngine configuration. I expect if config is DB_SCHEMA_UPDATE_FALSE, then version check only should happen and version mismatch is there, then an error will throw and engine should not start. But this config is not working as expected. Irrespective of true or false for this config, it is running the scripts and creating the new tables for the flowable upgrade.

How I can achieve this isolation of scripts and restricting flowable to upgrade the schemas. Is there any additional configurations required? I am using Flowable 6.5.0.



You sure it doesn’t work? Last time I checked, it did work for me, both FALSE and TRUE versions respecitvely.

  public EngineConfigurationConfigurer<SpringProcessEngineConfiguration> processEngineConfigurer() {
    return configuration -> {

Hai @fiki574,

No it is not working. I am using the following configuration.

My current flowable version is 6.4.0 and I am trying to upgrade to 6.5.0. The cofig setDatabaseSchemaUpdate is set to false and I am expecting to get an error due to version mismatch. Instead it is updating the tables. Is anything wrong with the configuration?


Okay, try adding this:

@ConditionalOnAppEngine //<---
public class FlowableConfiguration

And do the bean configuration with usage of EngineConfigurationConfigurer, just like I did up above. It doesn’t work for you because you’re not properly doing it.

Hi @fiki574

I have tried with this configuration also… Still not working… It is updating the tables…


I don’t know what’s the problem here then, the following thread contains all other snippets I needed to get it working: Spring Boot integration with a differnet database

Thanks @fiki574. I will try furthur…

Hey @joyal.joy777,

Why do you need to have @Primary on the process engine configuration that you are creating? If there is another engine configuration then it is most likely the cause for the problem.

The solution provided by @fiki574 in Disable Flowable Table auto create and manually run the scripts is the way to go.