Decision modeler import failure

I had the following error whenever importing DMN files into the decision modeler.

“Error while processing the DMN XML file : No decision services found in definition test.dmn”

This error occurs regardless of the context of the files. I have tried files that works well with DMN engine, files exported from the modeler itself, or files from the Flowable open source code. All of them had the same error.

I am using version 6.6.0

Can someone help?


there was a bug that caused this.
It is fixed on master (this commit) and will be included in the next release.



Yvo, thanks for the information. It is good to know that there was a fix.

I am using the war file so I assume I need to download decision-table-import.html the patch the war file. Will there be a patch release soon? something like 6.6.1? 6.6.0 was released in October 2020.


We’re planning to release a new version this month. Last year has been extremely busy, but it’s coming!

Import is working after patching the following file:

in flowable-ui-modeler-frontend-6.6.0.jar