Decision table does not deploy - no errors


#1

Using Modeler & Admin Console 6.3.1

We had an earlier (6.2.*) Model that had a decision task that invoked a Decision Table
both exported, put into Bar Archive, deployed fine, all worked

Now have a new Model invoking a Decision Table in the identical manner
both exported, put into Bar Archive, deploys OK - no errors reported anywhere
the Model deploys fine, the Decision table does not deploy at all

Cant figure out what changed (other than version of flowable) or why this deploy mysteriously does not happen for the DMN??

any pointers as to where to look to try and solve this issue ?

thanks


#2

Hi.

You mention that you deploy the process model and decision table with a bar file.
Could you elaborate on that?
Did you create an app and exported it as a bar file?

Regards,

Yvo


#3

I see what is causing the issue.
In Flowable 6.3.1 we introduced the App Engine.
One of the responsibilities of the engine is managing the relationships between the different engines and their models (bpmn / cmmm / form / dmn).
That’s why apps and bar files need to be deployed to this engine.
I notice that the possibility to do this from within the admin app is currently missing. This should of course be possible and we’ll fix this ASAP.

In the meantime there are (at least) 2 ways to get the bar / app correctly deployed.

  1. from the modeler app; deploy from the apps section
  2. via REST; use a REST client tool (or programmatically); POST [host:port]/[servlet-mapping]/app-api/app-repository/deployments. F.e.; POST http://server:9999/flowable-task/app-api/app-repository/deployments

Regards,

Yvo


#4

With 6.2 we exported the BPMN and the DMN into files, then zipped up together as one .bar
then deployed and all worked fine.

We are still using 6.3.1 but when I use the modeler and go to apps and create one, then try to add our process, it shows the process but there is no button or link to click to add it to the app… so still stuck

thanks


#5

Hi.

This should work.
Try the following;

  1. (in apps) create app
  2. select edit included models
  3. select the desired process model(s) (a plus sign will appear) and close
  4. the selected models will be shown in the details overview
  5. select save and mark the Publish box

Regards,

Yvo


#6

thanks this did work,

but it sure seems different from the established process of exporting a model and deploying via admin
whereas this deploys from modeler as soon as you save with publish on


#7

Hi,
i think, got same issue, i am not using modeler directly to my application,
downloading the .zip file and uploading through api method and still issue exists,

i am using 6.2.1 version and trying to design and deployed the workflow by downloading app .zip file from modeler,
deployed by below api call and worked fine first time able to see .dmn files in DB

Deployment deployment = repositoryService.createDeployment().enableDuplicateFiltering() .addZipInputStream(zipInputStream).name(fileName).key(deploymentkey).tenantId(tenantId).deploy();

but on second run, by adding one row in .dmn file, it is not versioning and no updates happens after second deployment in database

do i need to explicitly need to write a code for deploying .dmn files in second run?

Thanks,
Vzy


#8

Hey Vzy,

Have you seen this reply Can't get forms to deploy as part of application exported from Modeler from me? I think you are facing the same problem.

Cheers,
Filip