Unable to install Eclipse Designer


#1

Hi,

I am unable to install the Flowable Eclipse Designer.

Florian


#2

I downloaded it directly from the website and installed it that way.

Thanks
Florian


#3

Hi.

That’s strange.
I checked it and it appears to be working fine .

Regards,

Yvo


#4

This is also happening to me. I also tried:

  • Downloading the JAR (here) and adding it as an Eclipse repository, but it gave me a few other errors.
  • Downloading the code from GitHub and running Maven Install. That failed with a no repository found for Graphiti (Failed to load p2 repository with ID ‘Graphiti’ from location […]/graphiti/updates/0.13.1: No repository found at […]/graphiti/updates/0.13.1. -> [Help 1]).

URLs from error above were truncated by me since I can’t add more than two links here…

One thing I noticed is, if I try to visit the update site (this) with my browser, I get a warning from my router saying the site contains malware. Since other folks have had issues installing the designer, I’m not sure I should whitelist the update site…

Can anyone help?


#5

Hi,

What “other errors” did you get when using the download Designer zip as an Eclipse Repository?
Which version of Eclipse are you using?
If you visit an update site with the browser, it won’t work. It only works when using Eclipse to connect to it.

Best regards,

Tijs


#6

Hi Tijs,

I tried again today to check the exact errors, and it actually installed fine this time.

Sorry about that. Appreciate the reply!


#7

Hi,

Gotten this error:
Unable to read repository at http://www.flowable.org/designer/update/content.xml.

So not able to install the Flowable Designer.


#8

While installing Flowable designer in eclipse(Kepler) getting following error…

Cannot complete the install because one or more required items could not be found.
Software being installed: Flowable Eclipse BPMN 2.0 Designer 5.22.0 (org.flowable.designer.feature.feature.group 5.22.0)
Missing requirement: Graphiti (Incubation) 0.13.1.v20160830-1309 (org.eclipse.graphiti 0.13.1.v20160830-1309) requires ‘bundle org.eclipse.emf.transaction [1.8.0,2.0.0)’ but it could not be found
Cannot satisfy dependency:
From: Graphiti (Incubation) 0.13.1.v20160830-1309 (org.eclipse.graphiti.feature.feature.group 0.13.1.v20160830-1309)
To: org.eclipse.graphiti [0.13.1.v20160830-1309]
Cannot satisfy dependency:
From: Flowable Eclipse BPMN 2.0 Designer 5.22.0 (org.flowable.designer.feature.feature.group 5.22.0)
To: org.eclipse.graphiti.feature.feature.group [0.13.1.v20160830-1309]


#9

Has this issue been fixed? I am not able to install the plugin on Neon neither.

Running into the same error…


#10

Hi,

The Flowable Designer is not supported on Eclipse Kepler, it supports Mars and Neon.
Are you running into exactly the same error? That it can’t find the Graphiti dependency? Which version of Eclipse Neon are you using? Eclipse Java edition or JEE edition or something else?

Best regards,

Tijs