Unable to Install Eclipse Designer Plugin

I have Eclipse version 2021.12 but have tried this with versions as old as Mars and cannot get the plugin downloaded from within Eclipse. I continue getting the following error:
image

Please let me know if there is a solution or a workaround.

2 Likes

Hi, same behavior on my side. Looking forward to have a solution too…

Same here as well. Does anyone have a backup repository anywhere?

Same here, this was my first installation. I was following these guidelines:
Eclipse Designer · Flowable Open Source Documentation.
I hope this error can be fixed soonest.

[Edit] is this the possible reason, should I have access to that resource?

Is this fixed ?
I am seeing this issue in Eclipse build
Version: 2021-03 (4.19.0)

Build id: 20210312-0638

Please suggest if there is any solution

Kind Regards,
Abhishek A.

It looks like a documentation error? I tried below path, and able to install the plugin successfully.

I tried this suggestion but it failed:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Flowable Eclipse BPMN 2.0 Designer 5.22.0 (org.flowable.designer.feature.feature.group 5.22.0)
  Missing requirement: Graphiti (Incubation) 0.13.1.v20160830-1309 (org.eclipse.graphiti 0.13.1.v20160830-1309) requires 'osgi.bundle; org.eclipse.emf.transaction [1.8.0,2.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Graphiti (Incubation) 0.13.1.v20160830-1309 (org.eclipse.graphiti.feature.feature.group 0.13.1.v20160830-1309)
    To: org.eclipse.equinox.p2.iu; org.eclipse.graphiti [0.13.1.v20160830-1309,0.13.1.v20160830-1309]
  Cannot satisfy dependency:
    From: Flowable Eclipse BPMN 2.0 Designer 5.22.0 (org.flowable.designer.feature.feature.group 5.22.0)
    To: org.eclipse.equinox.p2.iu; org.eclipse.graphiti.feature.feature.group [0.13.1.v20160830-1309,0.13.1.v20160830-1309]