Missing requirement: Graphiti (Incubation)


#1

Hi, I have just tried adding Flowable Designer to my Eclipse but got an error saying about missing requirement - Graphiti (Incubation). Could you please suggest how to solve that? Thanks


#2

Hi, thanks for giving the Flowable Designer a try. Could it be that your Eclipse environment is not able to access to Internet the download the required plugins? You can also download the whole Designer package including the Graphiti feature from here flowable.org/designer/archived/flowable-designer-5.22.0.zip. Let us know if this doesn’t resolve your problem.

Best regards,

Tijs


#3

Thanks. I’ve tried installing from zip as well but I am getting the same:

Cannot complete the install because one or more required items could not be found.
Software being installed: Flowable Eclipse BPMN 2.0 Designer 5.22.0 (org.flowable.designer.feature.feature.group 5.22.0)
Missing requirement: Graphiti (Incubation) 0.13.1.v20160830-1309 (org.eclipse.graphiti 0.13.1.v20160830-1309) requires ‘bundle org.eclipse.emf.transaction [1.8.0,2.0.0)’ but it could not be found
Cannot satisfy dependency:
From: Graphiti (Incubation) 0.13.1.v20160830-1309 (org.eclipse.graphiti.feature.feature.group 0.13.1.v20160830-1309)
To: org.eclipse.graphiti [0.13.1.v20160830-1309]
Cannot satisfy dependency:
From: Flowable Eclipse BPMN 2.0 Designer 5.22.0 (org.flowable.designer.feature.feature.group 5.22.0)
To: org.eclipse.graphiti.feature.feature.group [0.13.1.v20160830-1309]


#4

Did you try running Eclipse as an admin? Some posts online seem to indicate this error could happen when running Eclipse with not enough privileges to install plugins.


#5

This looks like this thread.

Two things to verify are that when installing Contact all update sites during install to find required software is checked on and that you are using the correct version of Eclipse.

Finally there is the brute force way to meet the dependency on the emf jar; download emf from here “http://download.eclipse.org/modeling/emf/updates/releases/


#6

Running as an admin doesn’t help, contacting all update sites is checked during install.

I’m using Kepler where Activiti Designer worked without issues so it should work for Flowable as well?


#7

Hi,

This release of the Flowable Designer supports Mars and Neon.
Graphiti always supports two versions of Eclipse at the same time, so we can’t support Kepler anymore I’m afraid.

Best regards,

Tijs


#8

Understood, will try with Neon and will confirm, but most likely that’s the reason.

Thanks a lot for your almost real time support experience and good luck with Flowable 6.0! :smiley:


#9

Of course works with no issues on Neon.
Thanks again.


#10

How did you fix this issue? I am using Neon and still ran into the same issue.