Can't publish more than 1 imported process in the same app

I imported my old processes from activiti 5.23. When I put only 1 imported process in the app it works but it won’t work when i add one more imported process.

I tried changing the model keys of the processes but it didn’t work. Then I created an app with 1 process and published it to check the key from db table act_re_procdef, and noticed that the key was “process”. Then i checked the act_de_model table, the model_key was the one which i gave. I also checked the model_editor_json from the same table and process_id was correct. I downloaded the bpmn file and opened it with a text editor, the process id was “process” again.

I think it automatically changes the process id to “process” for every imported process so when I try to put 2 imported process in the same app it won’t work


Hi Ekin,

Could you create a Github issue and attach your example app so we can easily reproduce it?

Best regards,


Hi Tijs,
I fixed it by deleting

<collaboration id="Collaboration">
        <participant id="sid-24DC1BDD-F0C0-4937-A5AC-A19875C5109D" name="Proc 1" processRef="process"></participant>

from the bpmn file.