After deploying process by rest API, it is not visible in UI

Hi Team,

I tried to deploy a process by using POST[/repository/deployments]; it gave me success response but in UI I am not able to see the process.

thanks in advance.

Bibek Gupta

To make sure we’re on the same page; what do you mean with ; “in the UI Im not able to see the process”?


I mean in flowable UI (inside Moduler App in processes tab), I am not able to see the process deployed by me by using RestAPI

The models you see in Flowable Modeler are design models.
When you want to deploy these to the engine (or export it) the are transformed to definitions.
These 2 are different entities.
So when you deploy to the engine they don’t show up as design models.
If you want that. You need to import them in Flowable Modeler.

They will show up as process definitions in Flowable Task from which you can start instances.

Hello @yvo , how do I import them in the flowable modeler? Is there any swagger endpoint that I can use to import it?

In most cases you would like to do that from UI.
But there is a public REST resource for this;

POST http://localhost:8080/flowable-ui/api/editor/import-process-model



@yvo, I don’t see the mentioned endpoint in the deployed swagger. Could you please tell me what should be done to access this endpoint? Is this an internal endpoint?

Even if there’s no endpoint in swagger, you can trigger it via e.g. cURL or postman, no?

@joram I have tried it from the postman using the basic authentication and I get the response as html telling me to sign in.

The response has ‘Microsoft Corporation’ in it, this is not a Flowable URL.

1 Like