V5 process problem with flowable 6


I have this error in my log file.

Caused by: org.flowable.engine.common.api.FlowableException: Found v5 process definitions that are the latest version. Enable the ‘flowable5CompatibilityEnabled’ property in the process engine configuration and make sure the flowable5-compatibility dependency is available on the classpath

I understand that I have to enable Capability, but I just can’t find the file where I set the property <property name=“flowable5CompatibilityEnabled” value=“true” />

Can someone tell me the file name and location where I should set this property?



try to find flowable.cfg.xml.
Short blog about migration:


Hey @glaucocastro

How exactly are you using Flowable? How are you starting your application? Are you talking about the flowable-task application, your own application with a custom setup, your own application with Spring Boot or something else?


Thanks for the reply. So, I’ve read that blog post. That’s where I’ve found the information that I have to set this property. I’ve already looked for this file and it doesn’t exist in my system.

Thanks for asking. I’ve been trying to integrate flowable with Alfresco. During my searches, I found this project (https://citeck.com/news/flowable-and-alfresco-integration/) and it’s very interesting. Those guys have done a big job making the integration, but for some reason (and I think it’s something I’m missing), it doesn’t work. The main concept is to make Alfresco and Flowable read the same database where the workflows are. Even though I’ve set everythihg up as described in their documentation, it doesn’t work. Flowable works fine, but, Alfresco won’t see the models published by Flowable. So I thought to try something different. As Alfresco is pointing to it’s own Postgree database and seeing default workflows deployed there, I tried to point Flowable to this database. It seems it worked, as when I start the server up, Flowable complains about the v5 compability. I guess it’s seeing those models deployed by Alfresco by default. So, I was trying to set this compability mode so I could try this integration. I didn’t have much faith it would work, but at least it was worth a try.


So, does anyone have any suggestion of what I should do?