Unable to access flowable apps in WildFly


#1

After deploy of Flowable 6.3.1 on Wildlfy 8.2.0.Final unable to access the URL /flowable-idm which results in HTTP 403 Forbidden error and shows as " The website declined to show this webpage"


#2

Are you getting some exceptions?

What do you mean with your comment in Flowable-IDM Error with Wildfly and MSSQL [Resolved].

Where did you remove the spring dependencies from? The flowable-idm.war or Wildfly?


#3

" What do you mean with your comment in Flowable-IDM Error with Wildfly and MSSQL [Resolved]."

As I saw it as resolved, so replied to check what configuration changes are required

“where did you remove the spring dependencies from? The flowable-idm.war or Wildfly?”

  1. removed spring dependencies from the flowable-idm.war\WEB-INF\lib\ folder
  2. created a module as org/flowable/common and included following jars
<?xml version="1.0" encoding="UTF-8"?>

< module xmlns=“urn:jboss:module:1.1” name=“org.flowable.common”>
< resources>
< resource-root path=“flowable-spring-6.3.1.jar”/>
< resource-root path=“flowable-spring-common-6.3.1.jar”/>
< resource-root path=“commons-logging-1.1.1.jar”/>
< resource-root path=“sqljdbc4.jar”/>
< /resources>
< dependencies>
< module name=“org.flowable.common” export=“true”/>
< module name=“org.springframework.spring” export=“true”/>
< module name=“javax.servlet.api” export=“true”/>
< module name=“javaee.api” export=“true”/>
< module name=“javax.api” export=“true”/>
< / dependencies>
</ module>

  1. Updated the jboss-deployment-structure.xml with org/flowable/common dependencies
    < dependencies>
    < module name=“org.flowable.common” export=“true”/>
    </ dependencies>

To check if their is security issue , added below entry in standalone.xml

  1. included
    < security-domains>…
    < login-module code=“UsersRoles” flag=“required”/>"

But still results in Forbidden error


#4

I personally don’t have experience with Wildfly.

However, it seems that Wildfly 8.2.0.Final is quite old (release date 11th February 2014). I think that you should not exclude the spring dependencies from the flowable-idm.war, but the other way around. The flowable-idm.war uses Spring Boot 2.0 with Spring and Spring Security 5.0. Did you also remove the Spring Boot dependencies?


#5

did not remove spring boot dependencies… tried even removing spring boot dependencies but still same error.

Is their a way to deploy on JBoss?


#6

Is their a way to deploy on JBoss?

As I said I think that the version of Wildfly that you are using (8.2.0.Final) is really old and I am not sure if it is possible to run a Spring Boot 2.0 application on it. Spring Boot 2.0 requires at least Servlet 3.1 support for it to run. So if you can run on such JBoss then it is going to work.

Can you also make sure that there are no exceptions when the applications boots up? Or when the servlets get initialized.

Cheersm
Filip


#7

Hi Filip

I tried to deploy the same on JBoss EAP 7.0.0 and results in same “Forbidden error”

Have checked the server.log could not find any error . Is their a way to attach the log ?

I captured the trace log at start and as well as while accessing the URL.


#8

Was able to deploy 6.4.0 on Jboss EAP 7.1 GA but 6.3.1 has issues in deployment on Jboss EAP 7.1


#9

Not sure why 6.4.0 would work, but 6.3.1 won’t. Can’t you use 6.4.0?


#10

We can and we started using this. Found few issues related to Spring Boot - flowable rest calls, where most of calls fails to complete the task via Message Event subscription. When we check the logs the execution id returns null

  1. We first pass instance id to get subscription id
  2. Based on subscription id we call another Rest service call to compete the message subscription