No data in flowable-ui admin

I am using Flowable 6.5.0 within Spring-Boot application (with default h2 DB)
I have deployment, instances, tasks working well.
I wanted to check the monitoringaudit features.
So I run the flowable-ui in cmd line (java -jar flowable-ui.war), I can login but I can’t see any deployment/definition/tasks (i.e http://localhost:8080/flowable-ui/admin/#/tasks)
What configuration am I missing?
By default, I think both spring-boot-app and UI should point to the same in memory DB ?
Thanks for your help


Flowable Admin uses the Flowable REST API to fetch its data.
Is the REST API exposed with your 6.5.0 Spring Boot app? Then you could configure Flowable Admin to communicate with that.



Thanks Yvo.
I now started up flowable-rest from command line in port 8383, flowable-ui from command line in port 8282 and my Spring Boot application on port 8181.
I still don’t see data in the UI: http://localhost:8282/flowable-ui/admin/#/process-engine although I defined port 8282 (in admin: http://localhost:8282/flowable-ui/admin/#/engine and I clicked on “Check Rest endpoint” to check it’s ok).
Am I missing another configuration?

You want the data from the ‘8383’ instance… right?
Then you need to configure Flowable Admin to point these endpoints (and not the ones on port 8282)

I want the data from the 8181 instance where my main application run and read bpm files that I created with modeler, and registry config etc.) I run it locally with Intellij.
Then I started flowable-ui on port 8282 from command line and flowable-rest on port 8383 from command line.
When i configure in admin a port different that 8282, it fails to connect. but with port 8282, I dont see any data…

It sounds like you’re using different datasources for each instance.
Why do you start a different instance for Flowable REST?
Aren’t; or can’t you; expose the REST API in your Spring Boot application?

Also be aware that when you’re trying to use different Flowable versions using the same db schema this can cause issues.
When booting a 6.6.0 instance with 6.5.0 schema version it will update that schema. That will be nog problem. Running the 6.5.0 instance afterwards (using that same schema) will cause issues.

So long story short; if you want to expose the data you now have in your custom 6.5.0 Flowable app you best expose it via REST and use Flowable Admin to fetch that data. (Because of the decoupling via REST the safest route when you want to mix versions).
Or; export your models in the 6.5.0 instance via apps and import them in a 6.5.0 instance.

Hope this helps.


The problem may come from I run REST api outside of the spring boot application as you said.
I thought by default they all connect to the same local DB.
I will pay attention to the version. Indeed I am using 6.6 web apps although I am using 6.5 in Spring Boot.
So I will try to download 6.5 webapps and run REST API within my spring boot app.
Thank you Yvo.

Finally, I upgraded to 6.6.0 in order to match flowable-ui and flowable-rest webapps versions.
I integrated the REST api within my SpringBootApplication.
Didn’t know that there is a starter for this - thought I had to integrate the war manually.
I just had to add the following - if it can help someone :slight_smile:


And in the admin of flowable-ui, I changed the port accordingly and removed the context root.
Everything is working.


1 Like

Good to hear it’s working.
Thanks for reporting it.