Login page - site cant be reached

Hi, i have problem opening the HTTP:// page after a fresh install, it tries to redirect. I see there are similar forum threads but other users are able to get the first login page, and then it redirects. I can’t get the first login.

In one forum thread, they assume that flowable-rest is starting before flowable-idm and it creates users before the “idm”. I tried to start within tomcat management console one flowable application at the time but it won’t accept that. Is there a way to do that in tomcat (i am not an expert in tomcat administration).


  • freshly installed tomcat - working OK
  • copied all flowable wars in to web apps folder
  • tried to open HTTP:// (not the actual IP), remote access.

Tomcat is installed on Ubuntu 16.04, within a VMware ESXi. The server is accessed through a gateway with port and IP mapping. port 8080 is redirected to 8090 (8080 is occupied by jboss). I can easily access tomcat remotely and all other apps (JBoss, etc.) through redirects so this is probably not the problem

So after I hit HTTP:// it tries to redirect to another page, this is the URL:

the site is not opened and I get the message - This site can not be reached - localhost refused to connect.

I assume that modeler is passing authentication to idm but idm then redirects to the wrong address, it assumes that the flowable-modeler app is running on the which is public IP address and cant reach it, instead it should redirect to localhost:8090.


Can you sign in to Flowable’s IDM application?

When you launch a Flowable UI application (Modeler, Task or Admin) you will be redirected to Flowable’s Identity Management application to sign in. Sign in using the default user id: admin and password: test. You will then be redirected back to the Flowable UI application.

The Flowable UI applications take advantage of Spring Boot’s support for externalised configuration.



Thanks for the materials.

Yes i can access flowable-idm and login.

I understand from the “See” links that this can be changed in the properties files but then this is not easy out-of-the box installation any more. My intent was to explore the Flowable and decide will i go forward with it. Maybe documentation should be updated that changing the port requires additional configuration.

I have changed my tomcat to listen on port 8080 and things automatically worked. I had to change my jboss to another port though.

Another thing, prior to changing tomcat port to 8080 i tried instaling Flowable apps on Wildfly 10.0.1 and 18.0.1. Wildfly cant start, it throws lots of spring and database related error.
Does anybody runs Flowable on Wildfly

Example from widfly log.
Caused by: liquibase.exception.LockException: liquibase.exception.DatabaseException:
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘flowableAppEngine’:

The easiest way to get started with Flowable is to use a Docker image.

Take a look at the flowable/all-in-one image’s Dockerfile and update it to use Wildfly:

# FROM adoptopenjdk/openjdk11:alpine-jre
FROM jboss/wildfly:19.0.0.Final


COPY assets/flowable-idm.war.original /opt/jboss/wildfly/standalone/deployments/flowable-idm.war
COPY assets/flowable-modeler.war.original /opt/jboss/wildfly/standalone/deployments/flowable-modeler.war
COPY assets/flowable-task.war.original /opt/jboss/wildfly/standalone/deployments/flowable-task.war
COPY assets/flowable-admin.war.original /opt/jboss/wildfly/standalone/deployments/flowable-admin.war


Ref: How to deploy a Spring Boot WAR to Wildfly, JBoss or Tomcat