Flowable modeler logs

I modified an app by unzipping it, then renaming forms and form keys and making corresponding changes in the process file. Then I zipped the app back and tried to import it to Modeler app in flowable ui.
But I got error message “Error while processing the app definition file”.
How can I debug the error? I’m running flowable-ui on docker, but when I open the CLI terminal I cannot find any log files.

I put the app in a spring boot application tried to start it. Probably the easiest way the find out what was wrong. “Content is not allowed in prolog”. Obviously a false alarm as there is no content in the prolog nor any hidden chars before it. But that’s another story.


Modifying the app export archive outside of Flowable Modeler can cause all sorts of issues. Compression used etc. This is not a supported way of making changes to an app export.
Is there a reason not to chose to make the modifications inside Flowable Modeler and then making the export?



No. I just did not see the “duplicate this form” button.