Flowable Kubernetes (Cloud ) not able to access flowable-modeler, flowable-task

Dear Flowable Team,

We are trying to build a cloud ready project in which we are implementing the workflow feature using Flowable BPMN.

Facing issues in accessing the flowable-modeler, flowable-task.

Steps followed:

  1. Deployed all the docker images of flowable (https://hub.docker.com/u/flowable/ ) to Kubernetes.
  2. Configured all the required and optional environment variables.

Able to access http://flowable-idm-default.

While accessing below http://flowable-modeler-default. its being redirected to flowable-idm login page and after entering the credentials and submitting its again redirected to same flowable-idm login page.

Please help me resolve this issue.



this can be caused by several things.
But the first I’m thinking of is; did you set the property


When set this will be passed to the IDM app and will be used to redirect back after a successful authentication.
This is normally only needed when the components are hosted on different hosts.



@yvo Yes i have set this environment property.

Environment Config

Could you provide the IDM URL that the modeler redirects to?


Why is this different than the hostnames in your first post?
I’m asking because cookies need to be set.

@yvo Its resolving to host name and port automatically.

Tried with hard coding the complete url instead of service discovery, even then its not working.


Its always redirected to login page without any errors after entering the credentials.

1 Like

me too, the cookie not set.

something wrong? k8s ingress config or other?

same issue with me, seeme the cookie session not being set. after success authentication it fastly goes to flowable-task then again redirects back to idm.


are you serving the different containers behind a reverse proxy (in other words; from the same domain)?
Otherwise the cookie set in one container (=host) will not be readable in another.

And; did you have a look at the flowable-ui image? Because this serves the different applications from the same web root issues like these will probably be solved.