Error when starting to run a process

I was doing the steps in the documentation, where we are going to interact with REST API in order to execute a process instance. However, I got an error where it says

Any pointers of my mistake will be appreciated :slight_smile:

Hello,
I suggest you to go to the following url to discover and test rest api :

It’s really self-explained.

JC

Hey JC, thanks for telling me the documentation however can I ask you a question, so I was following the Spring Integration from the documentation. I was at this point;

We can now start a new process instance, providing the user name in the POST body:
curl -H “Content-Type: application/json” -d ‘{“assignee” : “jbarrez”}’ http://localhost:8080/process

I tried the command from the flowable-rest documentation and it results to this:

.

Which I believe its all process that I have assigned to the user “jbarrez” (please tell me if I am wrong). So with this assumption, I have assigned 3 process to “jbarrez” and when I am going to fetch the tasks assigned to him, somehow it shows 0 tasks which is weird since each process has one user task.

What am I missing here or perhaps I got it all wrong? Thanks a bunch!

One item I frequently forget in the modeler is to set the assignee on my user tasks. Did you update your BPMN as instructed:

<userTask id="theTask" name="my task" flowable:assignee="${person.id}"/>

When the task starts it will look for an id attribute on a person object in the process variables.


Side note: Piping your curl commands through jq will make the output more readable.

Hello, yes I did update my BPMN but this is the result:

{“timestamp”:“2019-10-21T02:22:24.282+0000”,“status”:500,“error”:“Internal Server Error”,“message”:“Unknown property used in expression: ${person.id}”,“path”:"/process"}

The command that I used is: curl -H “Content-Type: application/json” -d “{“assignee”: “jbarrez”}” http://localhost:8081/process

Ok, I just ran through the doc to this point (I skipped changing the datasource to mySQL). The only issue I ran into is that the entity class should be public if it’s in a different file. Are you getting a stack trace on the Java side when you execute curl -H “Content-Type: application/json” -d “{“assignee”: “jbarrez”}” http://localhost:8081/process

Try changing:

@Entity
class Person {

to

@Entity
public class Person {