Setting database schema name

I have a separate schema for storing Flowable tables which I create manually in all environments. My spring-boot app needs to connect to this database using an application user which has read, write and delete privileges. My DBA does not like applications connecting to the database with Schema Owner users. I am adding all the grants to all the tables for this APPLICATION_USER however my spring-boot app fails on startup as it cannot find the table. After some debugging I found out the issue is because I am not prefixing the schema to use. Is there a way to tell flowable engine to prefix all the queries with a schema name which might be different than the datasource creds we are using to connect to the database?

select * from ACT_GE_PROPERTY; → does not work

I have tried adding a schema.sql which runs on startup and setting the current schema to be the schema owner, the application starts up and I see all the sql queries are being prefixed with schema_owner.table_name correctly. The queries in TimerJob.xml though are not getting prefixed though and I see table not found errors. I am not sure why these are behaving differently to other queries.

I see there is a field in “DbSqlSession” class called “connectionMetadataDefaultSchema” which seems to be what we need to set, I am having trouble finding where this can be set.

There are a couple of properties that you need to set.