Newbie question - Why do REST API uploaded process not shown in flowable-admin/#/process-engine?

Hello flowable,

I followed along the Getting Started with Flowable REST API guide and tried uploading a process definition…

After I have successfully deployed the holiday request process using Postman, tried to compare what I saw on

  1. REST API GET request localhost:8080/flowable-rest/service/repository/process-definition
  2. And http://localhost:8080/flowable-admin/#/process-engine

Surprisingly they are different. Aren’t the processes the same? They are stored in different databases? Where are those?

Hope to hear from you. Thanks.

Regards. Kim.

It depends how you are running it. If you point flowable-admin to the same instance, then it will show all the data of that engine. How have you set up the applications?

I put the war files separately into the webapps folder. So they are in diff instances :).

Joram, may I suggest that you make a remark in the REST API Getting Started Guide that the flowable-admin is NOT running on the same instance as the REST API’s.

Otherwise, someone new might be caught by surprise that there were no tasks assigned to the managers group even if the holidayRequest process has been deployed and started, because the managers group does not exist in the REST API (there were no instruction to create one).