Need some help getting started with docker-compose

Hi there,

I was looking for the simplest way to test flowable, and the all-in-one iamge sounded best although it seems its 3 years old:
Docker Hub with the instruction:

docker run -p 8080:8080 flowable/all-in-one

Unfortunately all that gives is the default tomcat starting page:

I googled a bit and tried this but it did not change the result:

docker run -p 8080:8080 -e flowable/all-in-one

The next thing I tested was: flowable-engine/ui-postgres.yml at main · flowable/flowable-engine · GitHub
I saved that file as docker-compose.yml and did a docker compose up -d

There are no errors I can see in the logs, but the result is: “HTTP Status 404 - Not Found”

Can someone point me towards some instructions or give me some tips how to pull up flowable for testing it please? I’m intending flowable to run on a docker host and access it from my local workstation via browser so not from the same machine it rusn on.

The all in one image is quite old. Better to use the new approach: see instructions here Docker Hub

Thanks, I’ll give that a try. It says “Part of the Flowable eco system.” would you kindly point me towards where I find the other parts of this eco system?

Is this the only other part of this eco system: Docker Hub ?

I need to figure out which parts there are and which parts I need. All the links on the .org site I tried following to figure this out point to the .com domain. Not sure those two carry info about the same “parts” of flowable.

Hi @ovizii

Thanks for pointing out that some info is currently missing in the documentation. This was caused due to a recent restructuring of the docs. We will improve this in the near future.

In the meantime you can have a look here. Some docker compose examples with different configurations can be found here.

This in addition to the DockerHub pages that Joram pointed out.

I hope this helps.



ps. I see you found these docker compose configs already. Did starting with f.e. docker-compose -f ui-postgres.yml up -d not work for you?
Did you make sure no containers were already running?
Can you share the logs of that command?

Hi and thanks for helping me out. This only gives me a “HTTP Status 404 – Not Found”

docker-compose -f ui-postgres.yml up -d
reating flowable-ui-postgres ... done                                                                                                               
Creating flowable_flowable-ui-app_1 ... done

Here is a link to the full log: flowable-ui-postgres | The files belonging to this database system will be owne -

Are you using the correct context path?
meaning; http://localhost:8080/flowable-ui/?

Please disregard my post, I overlooked the “flowable-ui” part :frowning: my apologies.

Perfect, it is up and running, now I can properly test it, thanks for helping me out!
Also, it looks like this is all I need, I see 4 parts of the eco system so I guess this is it.

1 Like