Missing dependencies in admin app?


i was trying out the new http task to call a rest api and while trying to visualize the data about it in the admin app it appears i could not because of the error “ClassNotFoundException: org.flowable.http.impl.HttpActivityBehaviorImpl”.
I tried to copy / paste the flowable-http jar in the flowable-admin directory in tomcat but it did nothing (not sure how the whole thing works behind the scene though).

Is it a bug or did i miss something in the installation (i dropped the war in the tomcat webapp folder like in 6.0.1) ?



Are you using the Flowable REST app or the Flowable Task app? The flowable-http JAR needs to be added to the app running the process engine (the REST app or the Task app), and not the admin app because that’s just doing REST calls to the process engine application.

Best regards,


Thank you for the answer, after adding the jar as you indicated it worked perfectly :slight_smile:

I encountered a similar problem with the executions part of the rest api where i was getting .notFoundException for org.apache.http.ssl.truststrategy in the json response. I resolved it by adding the httpclient and httpcore jars in the flowable rest directory.

Now i’m stuck again with three problems :

  1. In the flowable-admin app, in the “form engine” tab when i click on the “definitions” sub-tab i get an error message “we couldn’t get the data from the server” and i get this trace in my Eclipse (STS) console : GRAVE: Servlet.service() for servlet [dispatcher] in context with path [/flowable-admin] threw exception [Request processing failed; nested exception is org.flowable.admin.service.engine.exception.FlowableServiceException: An error occurred while calling Flowable: HTTP/1.1 404 Introuvable] with root cause. But the admin-app is up and running, i can access it without problems

  2. In the flowable-task app, in the “tasks” tab, tasks from programmaticaly started processes make the page refresh continuously (as if i was spamming F5) but whenever i create a task through the “create task” button the page works perfectly.

  3. For this one, i’m not sure if my understanding of what is supposed to be shown is correct : in the flowable-admin app, in the process-engine tab, i’m able to see my deployments and definitions but instances and tasks are always empty whether i launched a process (with a user task for example) programmaticaly or if i create a task manually (with the “create task” button)

Thank you,

PS: for new questions like those, is it best for you guys if i create a new thread or not ?

Hi Reivax,

The questions are related to your first question, so that’s fine :wink:

  1. Correct, we found this bug also, we will make sure it gets fixed for the next 6.1.1 release. You could create a Github issue to track it.

  2. Interesting, we’ll do some testing. Could you create a Github issue?

  3. When you create a process instance from the Flowable Task app, does it show up then? Do you see any error in the server log or the Javascript console?

Best regards,


Hi tijs,

1 ) i created a github issue to track it as suggested here is the link : https://github.com/flowable/flowable-engine/issues/449

  1. Here is the github issue for this one, i added more details in the issue, hope it helps ! https://github.com/flowable/flowable-engine/issues/450

  2. I created a process instance from the flowable task app and the process instance and the associated task do show up in the appropriated tabs on the contrary of the programmaticaly started process ( and associated task ).

I don’t have any error in my server’s console and the only error in the javascript console was an internationalization one because it was searching for a language file corresponding to my native language (fr-FR.json) which i fixed by copying, pasting and renaming the en.json file in the appropriate folder but it had no effect on the discussed error.

Thank you,