How to stop Deployed Flowable Apps from picking jobs


#1

Hi,

I have a process with timer start event having expression “R10/PT5M”. This process contains a Service task which uses expression “${UtilityServiceTasks.sendDropLinkMails(execution)}” which is defined in my spring boot application. Now this process is deployed using flowable modeler app. Now my spring boot is also running on my local machine connected to same database. Now when the timer expired, instead of spring boot process engine picking up this job, this job is picked up by apps deployed on tomcat and so it throws

" Unknown method used in expression: ${UtilityServiceTasks.sendDropLinkMails(execution)}"

How can i make sure that job is picked up by the spring boot process engine and not by deployed app so that i dont get this error?

Thank You,
Arpit Agrawal


#2

Jobs will be picked up wherever you’ve got the AsyncExcutor running. So in this case, it looks like both your Spring Boot app and the Flowable task app have the async executor running. You’d have to disable the executor on the task app if you don’t want it to pick up jobs.


#3

Hi joram,

Can you tell me, how i can do that? Is their a property in flowable-app.properties which i can change or do i need to add that property to flowable-app.properties?

Thank You,
Arpit Agrawal


#4

Hi Joram,

Is this the property i need to set to false?

Thank You,
Arpit


#5

Hi Joram,

Here, in flowable-ui-task configuration, instead of using environment properties, it is using true directly. How can i change this without needing to change the code?

Thank You,
Arpit Agrawal


#6

Had similar issue and I was able to turn off the asyncExecutor by editing/creating a ./WEB-INF/classes/engine.properties in the flowable-rest app with the below properties:

engine.process.asyncexecutor.activate=false

If you search for the above property you should fine some notes/documentation on it.

Hope this helps


#7

Hi Zoheb,

Thank you. But the problem is their is no flag to stop flowable-task executor. But for now the issue is resolved.

Thanks,
Arpit Agrawal


Not starting Async executers on admin applications
#8

In the upcoming 6.3.0 release, there will be a property for this: see https://github.com/flowable/flowable-engine/blob/master/modules/flowable-spring-boot/flowable-spring-boot-starters/flowable-spring-boot-autoconfigure/src/main/java/org/flowable/spring/boot/FlowableProperties.java#L32


#9

Hi Joram,

What about flowable-task async executor. Currently the flag is not available in the .properties file. How can i control that if i want to use flowable-task on the same database as my spring boot project?
Currently i had to go to the code, change their and build the war myself. Can that also be done through .properties in 6.3.0?

Thank You,
Arpit


#10

In 6.3.0 the apps would be Spring Boot based. You would be able to configure that with a property, in the same way you can configure any Spring Boot application.


#11

In 6.3.1, i tried to set following properties to false for job not to run in flowable-rest.war, but still the jobs are getting fired and yet property not found exception is thrown

flowable-default.properties

                  flowable.async-executor-activate = false

engine.properties

                   engine.process.asyncexecutor.activate=false

#12

Try setting
flowable.asyncExecutorActivate=false


#13

For Spring Boot 2.0 there is no difference between the flowable.asyncExecutorActivate and flowable.async-executor-activate properties. They are the same property.

@suds do you have the flowable-task.war also running in the same container?

Cheers,
Filip