Error building a process engine in ColdFusion

So I’m using an oracle 12c database as the storage for the process repository. I’m playing around with trying to get this to work in ColdFusion, which is java runner under the hood. I created a Java Class to build the process engine and it is able to connect to my database and build the process engine. Yet when I attempt to execute this exact same code in ColdFusion, I keep getting an error. For reference, the init() function is how you do a constructor in ColdFusion.

I’m not getting any log info, just a 500 error that points at


This is the code I execute:

var config = createObject(‘java’, ‘org.flowable.engine.ProcessEngineConfiguration’);

var processEngineConfig = createObject(‘java’, ‘org.flowable.engine.impl.cfg.StandaloneProcessEngineConfiguration’).init();


processEngine = processEngineConfig.buildProcessEngine();

Any ideas on what’s going on here, or where I should look for more help on this problem? As a note, this code was adapted from what I used with Activiti version 6.0, and it worked for Activiti just fine.


Which JARs do you have in the classpath? If you don’t disable the idm engine (processEngineConfig.setDisableIdmEngine(true)), then you need the flowable-idm-engine-configurator JAR file on the classpath as well.

Best regards,


So I checked my JARs and this was a dependency problem. IDM JARs were missing, and some of the other JARs were from an earlier version of Flowable. So I cleaned up the JARs and replaced them with the 6.3.1 versions and it works now.