Saving long values in TEXT_ column instead of as a bytearray

I want to save all the long text or description greater than 4000 in the same TEXT_ column instead of saving it as bytearray in the table act_hi_varinst_.

Please suggest how can this be achieved. I want to save JSON values in the TEXT_ column instead of saving it is bytes in the act_ge_bytearray table and having the ID_ in the act_hi_varinst_ column.

I tried changing the datatype of the column TEXT_ in act_hi_varinst table to TEXT instead of varchar(4000) but it still saves as a bytearray.

Adding I referred this post, where it mentions about removing VariableLongType from flowable-engine configuration. Where do I need to make these changes?

Hey @pratikpbhagat,

You can achieve this by setting the maxLengthStringVariableType on the ProcessEngineConfiguration. If you set that then the StringType will always be used and that stores the data in the TEXT_ column. If you want to be extra sure you can try adding your own StringType before the current `StringType.


Thanks for the reply.

Is this something that can be changed in the properties file as I’ am using the flowable apps as WAR file.