Remove lock owner and lock time in act_ru_job

Sometimes when I restart my server where Folwable Engine is running. Jobs get stuck.
Meaning though the lock_exp_time_ has passed , the lock never clears.

I have checked asyncExecutorResetExpiredJobsInterval this is set to 1 minute(Default).

Now I want a way to best way to remove locks for such jobs.

Currently I am clearing them manually
update act_ru_job set lock_owner_ = null , lock_exp_time_ = null where lock_exp_time_ < now()

The reset expired thread should pick this up. You’re saying it doesn’t remove the lock after a reboot, even after a minute?

Yes, that’s similar to what the reset expired logic should do.

We are also seeing similar behavior where jobs are getting locked and works fine after restart - updating from database doesn’t seem a solution. This is even caused with normal job execution (few jobs) - looking at the Flowable documentation they recommend using dedicated Message queues which might be a viable option if there is too many job execution to be processed which is not the case with our app.

I am trying to fine tuning my job executor pool settings

Other fine tuning could be done using some good article here

Still trying to explore above options but are there any known issue or better suggestions.


There was a bug with resetting jobs, that is fixed on current master. Which version are you using?

Missed your reply - we are on flowable 6.5 version.