Redirected to login page when trying to access flowable modeler, flowable task


when i’m trying to access localhost:8080/flowable-modeler, i am being redirected to the login page:


kindly help me to resolve this issue.



But, what is the question? “Flowable” has need authenticate before to operate with modeler/task/…

Hi Sahil,

Its not an issue. You need to authenticate before accessing any other flowable app. You can use username: “admin” password: “test” (provided by default from flowable) to access any app.

Note : All though you may see kermit, gonzo or fozzie as users in the IDM app, but only “admin” has the “privilege” to access modeler,task etc app. So, no other username/password combination will work.

Thank You,
Arpit Agrawal


The kermit, gonzo and fozzie users are a bit of legacy users that are created as part of the flowable-rest application. For the Task, Modeler and Admin apps there’s one default user created, name “admin”. You can of course add any additional user as you like via the IDM app or plugin your LDAP system.

Best regards,



the issue is that when i enter the username/password as amin/test, it again redirects me to the login page

1 Like


the issue is that when i enter the username/password as amin/test, it again redirects me to the login page, i am not able to access any app like modeler or task.


Hi Sahil.

If you looks at your ACT_PRIV_MAPPING table, most probably it will empty. So even if you login through admin/test it will redirect you to login page again bcoz admin using is not assigned the privilege.

This is how your ACT_ID_PRIV tables should look like by default :
| ID_ | NAME_ |
| 5b41b43a-ca01-11e7-9c0e-0242eb4b7588 | access-idm |
| 5b59a90c-ca01-11e7-9c0e-0242eb4b7588 | access-admin |
| 5b8b405e-ca01-11e7-9c0e-0242eb4b7588 | access-modeler |
| 5b9dde00-ca01-11e7-9c0e-0242eb4b7588 | access-task |

and this is how your ACT_ID_PRIV_MAPPPING table should look like by default:

| 5b4dc22b-ca01-11e7-9c0e-0242eb4b7588 | 5b41b43a-ca01-11e7-9c0e-0242eb4b7588 | admin | NULL |
| 5b6a98fd-ca01-11e7-9c0e-0242eb4b7588 | 5b59a90c-ca01-11e7-9c0e-0242eb4b7588 | admin | NULL |
| 5b96b20f-ca01-11e7-9c0e-0242eb4b7588 | 5b8b405e-ca01-11e7-9c0e-0242eb4b7588 | admin | NULL |
| 5ba298f1-ca01-11e7-9c0e-0242eb4b7588 | 5b9dde00-ca01-11e7-9c0e-0242eb4b7588 | admin | NULL |

If your ACT_ID_PRIV_MAPPING table is empty then, you won’t be able to access any app.
(Note: ID_ and PRIV_ID_ columns data might be different for your database by all other columns should be same for default installation)

You can refer to this post :
Unable to login to Flowable UI applications after a fresh installation

Most probably, above post will solve your problem.

Thank You,
Arpit Agrawal


Did you manage to resolve the issue? I have faced the same problem.

Please give me some advice on how I should approach the issue!


Hope this helps :

Thank You,

Thank you! :grinning:

Hi, my ACT_ID_PRIV_MAPPPING table looks like (supposed to be) the correct one. However, the app keeps redirecting. Anything I can debug with?


I have the same issue. My tables look like expected but after I login with my credentials, I get redirected to the login page.


Flowable 6.3.0
Tomcat 9.0.1

EDIT: I’m only able to login to IDM successfully (without the false redirect)
EDIT 2: I also set the org.apache.tomcat.util.buf.UDecoder.ALLOW_ENCODED_SLASH=true flag without success.

1 Like

After reverting most of the settings it worked again. I currently only use the database connection from the shared lib/config folder. I can’t find anything in the documentation which could cause this, but maybe it helps someone else too.

Okay forget the above. It’s not working when you delete the default users. Even if you have a new user with the same credentials it’s not working. So just “DON’T DELETE THE DEFAULT USERS” worked for me.

There seem to be two issues at play: the empty user table issue referenced elsewhere in the comments, and Spring Security intervening. I have just created this issue.


How can i redirect or cloe this issue, if i am using my own identity application instead of flowable-idm?


Do we have a solution for this. I am trying to set this up in our Openshift cluster and I am facing the same issue. I have checked both the tables and its look good as per the suggestion above.

Is there anything else, I am missing?

@sidhlipu could you explain what the issue is?
This is an older topic which covers areas that had changes. This means the analysis may not be valid anymore.


@yvo , thank you for your reply. I was using an older image which was 6.5. Using 6.6 fixed the issue.

Hi, I am using all-in-one image which is of the version 6.5.0 by default. Is 6.6.0 version present in Docker hub? I am also facing the same redirection issue as that of the rest of the users. I have the correct entries in act_id_priv_mapping and act_id_priv table. What is the recommended solution to this issue? I have checked all the links mentioned in this forum but was unable to get a concrete solution to this issue. Any help will be appreciated. Thanks.

Check What’s new with the Flowable UI Apps – Flowable Blog and Docker Hub