NullPointerException at org.flowable.engine.impl.db.ProcessDbSchemaManager.schemaUpdate

Hello everyone,
I have a very simple vanilla project with SringBoot 2.2.4-RELEASE and Flowable 6.5.0. It contains a simple process definition, the process starts when reads a message from Kafka and then logs a message. Until a few days ago it was working fine, now I get this error:

The strange thing about this is that I’m getting the same error on other projects with flowable, could you please help me find the issue?

Let me know if you need more information about the project.

Thank you,

Update: I’ve introduced in a new project the flowable dependency v 6.5.0 and i get this error:

It seems that is being caused by Liquibase (as suggested here:, so i tried updating Liquibase’s version to the latest (4.1.1) but i still have this problem…

Hey @nrus,

It seems like you have updated your database to Flowable 6.6.0 and then you try to run Flowable 6.5.0. This is not possible. You either need to drop your database and use 6.5.0 or use 6.6.0.


Hi @filiphr, thank you for your quick response. You were right, I dropped all the tables and I re-runned the app…now it’s working, thank you!