Imported Model is not Visible in Flowable Modeller

Hi I used eclipse to model the process and it works fine. I can also create process instances through java code and complete the process. However I am not able see the process defination when login using flowable modeller. Is there anythig I am missing in setup. I am in Flowable 6.6.0.

I also tried to import the model xml file and it imports fine. It allows me to make all the changes in the model and also it gets saved to the DB. However when I close the window the model is not visible in the modeler.

That’s really weird - if you import it, it is saved to the database and is there until you delete it. What kind of setup are you using? Are you perhaps using an-in memory database + a setup that shuts down services automatically?

I am using Oracle DB. Through Eclipse I am able to everything. The model does get saved to DB but not visible in the Process modeler. Is there any setting I need to change?

How do I check if the setup is shutting down the services automatically. I can see the process is getting saved into db but still not vislble in the model.

I’m not sure I’m following you. The Eclipse plugin doesn’t have a database where it stores things.
If you’re using Oracle, you should be able to see the contents of the database table ACT_DE_MODEL, which should contain your model.

My Installation: Tomcat and Oracle DB
Model gets saved in ACT_DE_MODEL with Process Designer. I don’t see any error in the TOMCAT log but I don’t see the model in the Process Designer.

Please let me know if you need any other information.

I have the same issue with Modeler for Flowable-6.6.0 installed on Tomcat and Oracle DB.

When I create a model it gets saved to ACT_DE_MODEL table, however after the save, the model is not visible in the Modeler.

@insrath, were you able to figure out the issue?

That’s really strange - are you sure you have configured the database correctly? What happens on the network tab when you click save?

There are no errors on the Network tab when I click save and the model does get saved to the ACT_DE_MODEL table.

The /flowable-ui/modeler-app/rest/models?filter=processes&modelType=0&sort=modifiedDesc also returns with a 200 status in the Network tab.

However, if I try to execute the above rest call from SoapUI with the admin/test credentials, it returns a 401 error. Hence, wondering if I missed some configuration.

Regarding the database: I updated the spring.datasource.* properties in the file to point to the Oracle DB and deployed the flowable-ui.war to Tomcat’s webapps directory and the database objects got created on their own.

Checked the response for the models rest call under Network > Response and it shows:


I could not make it work with Oracle. It works fine with Mysql, Postgres and default H2. Did not find anything in the log. I am doing everything from Eclipse plug-in which is little cumbersome. I am in the process of moving to a different BPM platform.

Found an issue reported at this URL:

So as a workaround, set the = “tenant1” in

Now “tenant1” gets saved in the ACT_DE_MODEL.TENANT_ID column upon saving the model and the model gets retrieved from the database & is visible in the Modeler.