# Unable to start Flowable 6.3.0 with Postgresql 9.6

**URL:** <https://forum.flowable.org/t/unable-to-start-flowable-6-3-0-with-postgresql-9-6/2000>\
**Category:** Flowable Engine\
**Created:** [May 9, 2018, 9:44am UTC](https://forum.flowable.org/t/unable-to-start-flowable-6-3-0-with-postgresql-9-6/2000 "2018-05-09T09:44:41Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tony-C](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/tony-c/32/675_2.png) [@Tony-C](https://forum.flowable.org/u/Tony-C)\
**Post date:** [May 9, 2018, 9:44am UTC](https://forum.flowable.org/t/unable-to-start-flowable-6-3-0-with-postgresql-9-6/2000/1 "2018-05-09T09:44:41Z")

</div>

Hi,

I have downloaded flowable-6.3.0.zip, run the db script flowable.postgres.all.create.sql in postgresql 9.6,  
modified application.properties for flowable-admin.war, flowable-idm.war, flowable-modeler.war, flowable-rest.war and flowable-task.war as floowing,

#spring.datasource.driver-class-name=org.h2.Driver  
#spring.datasource.url=jdbc:h2:tcp://localhost/flowableadmin  
#spring.datasource.url=jdbc:h2:~/flowable-db/db;AUTO\_SERVER=TRUE;AUTO\_SERVER\_PORT=9091;DB\_CLOSE\_DELAY=-1

#spring.datasource.driver-class-name=com.mysql.jdbc.Driver  
#spring.datasource.url=jdbc:mysql://127.0.0.1:3306/flowable?characterEncoding=UTF-8

spring.datasource.driver-class-name=org.postgresql.Driver  
spring.datasource.url=jdbc:postgresql://localhost:5432/flowable

Deployed war into tomcat 8.5.30. Only flowable-admin and flowable-modler able to start,  
flowable-idm.war, flowable-task.war and flowable-rest.war failed to start due to following error.

2018-05-09 12:19:03,041 [localhost-startStop-1] ERROR org.flowable.engine.common.impl.db.AbstractSqlScriptBasedDbSchemaManager - Could not get property from table ACT\_ID\_PROPERTY  
org.postgresql.util.PSQLException: ERROR: permission denied for relation act\_id\_property  
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2433)

I have checked flowable database, the table is exists.

Any idea why still not able to read ACT\_ID\_PROPERTY table even though it is exist?

---

<div class="post-metadata">

**Author:** ![maudrid](https://avatars.discourse-cdn.com/v4/letter/m/e56c9b/32.png) [@maudrid](https://forum.flowable.org/u/maudrid)\
**Post date:** [May 9, 2018, 3:49pm UTC](https://forum.flowable.org/t/unable-to-start-flowable-6-3-0-with-postgresql-9-6/2000/2 "2018-05-09T15:49:24Z")

</div>

Have you checked that the user has permissions to see the table?  
I’ve also encountered that (depending on your configuration) the engine is looking in the public schema instead of the one you designated.  
At one point we had set up a user for flowable that has our flowable schema as it’s default instead of the public schema.  
Hope this helps.

---

<div class="post-metadata">

**Author:** ![filiphr](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/filiphr/32/315_2.png) [@filiphr](https://forum.flowable.org/u/filiphr)\
**Post date:** [May 9, 2018, 6:26pm UTC](https://forum.flowable.org/t/unable-to-start-flowable-6-3-0-with-postgresql-9-6/2000/3 "2018-05-09T18:26:44Z")

</div>

@Tony-C if you are manually installing the SQL you would need to disable the automatic update from Flowable. You can do that by setting `flowable.database-schema-update=ignore`

---

<div class="post-metadata">

**Author:** ![Tony-C](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/tony-c/32/675_2.png) [@Tony-C](https://forum.flowable.org/u/Tony-C)\
**Post date:** [May 10, 2018, 4:44am UTC](https://forum.flowable.org/t/unable-to-start-flowable-6-3-0-with-postgresql-9-6/2000/4 "2018-05-10T04:44:13Z")

</div>

@maudrid, Thank you so much. Indeed it is the user permission issue. I have fixed and it is working now. It is very helpful!

---

<div class="post-metadata">

**Author:** ![Tony-C](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/tony-c/32/675_2.png) [@Tony-C](https://forum.flowable.org/u/Tony-C)\
**Post date:** [May 10, 2018, 4:45am UTC](https://forum.flowable.org/t/unable-to-start-flowable-6-3-0-with-postgresql-9-6/2000/5 "2018-05-10T04:45:42Z")

</div>

@filiphr, Thanks for your tips to disable automatic schema update.
