Timer events not firing

Hello everyone, we’ve encountered an issue with timer events and would be glad for some assistance.

Currently in our process we have a boundary timer event attached to some user task and also an intermediate timer event.

The expected behavior is that once we reach said event, the timer will fire.
Unfortunately this isn’t the case and we are left waiting…

We tried creating an event listener to listen for timer events (timer_scheduled and timer_fired) and the only event that triggered was timer_scheduled.

Our configuration is flowable version 6.2.1 (embedded), along with spring boot 1.5.10 and java 1.8.
We are also using the following version of spring cloud: Dalston.SR4.

Thanks for any advice.


Just to be sure. Did you enable async executor in process engine configuration?


Hey Martin,
Thanks for the quick reply.

The async executor is enabled.

Might you have any other suggestions?
Thanks again.

Hi Dany.

My guess is that it is a configuration problem. There are plenty of tests and solutions which use timers. Could you prepare simple jUnit test with your configuration?


Hey @Dani700,

What do you exactly mean with this?

How are your timers configured? Can you perhaps provide us with your BPMN file?


Hi Team,

I’m also facing the same issue.

Tried by enabling asyn aactivation by the following


I’m also waiting for this answer

Hey @maheshus007,

Not sure for what kind of answer you are awaiting, we have already answered this question and requested for more information since it is not clear to us.

If you are referring to your own post here, please don’t do that. We are going to reply to your post there, no need to resurrect old posts