# Still get error if use non-default port and IP

**URL:** https://forum.flowable.org/t/still-get-error-if-use-non-default-port-and-ip/1335
**Category:** Flowable Application
**Created:** [December 15, 2017, 3:46am UTC](https://forum.flowable.org/t/still-get-error-if-use-non-default-port-and-ip/1335 "2017-12-15T03:46:23Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![johnny2002](https://avatars.discourse-cdn.com/v4/letter/j/65b543/32.png) [@johnny2002](https://forum.flowable.org/u/johnny2002)
#### Post date: [December 15, 2017, 3:46am UTC](https://forum.flowable.org/t/still-get-error-if-use-non-default-port-and-ip/1335/1 "2017-12-15T03:46:23Z")

</div>

Since I installed flowable apps on a difference machine other than localhost and 8080 port, I still got error information while deploying app.

---

<div class="post-metadata">

### Author: ![johnny2002](https://avatars.discourse-cdn.com/v4/letter/j/65b543/32.png) [@johnny2002](https://forum.flowable.org/u/johnny2002)
#### Post date: [December 15, 2017, 3:50am UTC](https://forum.flowable.org/t/still-get-error-if-use-non-default-port-and-ip/1335/2 "2017-12-15T03:50:24Z")

</div>

I am now using 6.2.1,  
While it works @6.1.2

---

<div class="post-metadata">

### Author: ![johnny2002](https://avatars.discourse-cdn.com/v4/letter/j/65b543/32.png) [@johnny2002](https://forum.flowable.org/u/johnny2002)
#### Post date: [December 15, 2017, 4:11am UTC](https://forum.flowable.org/t/still-get-error-if-use-non-default-port-and-ip/1335/3 "2017-12-15T04:11:16Z")

</div>

Since I cannot upload the log file, just paste part of it:

12:05:43,006 [ajp-nio-8009-exec-9] DEBUG org.apache.http.headers - http-outgoing-6 \<\< Content-Type: text/html;charset=utf-8  
12:05:43,006 [ajp-nio-8009-exec-9] DEBUG org.apache.http.headers - http-outgoing-6 \<\< Content-Language: en  
12:05:43,007 [ajp-nio-8009-exec-9] DEBUG org.apache.http.headers - http-outgoing-6 \<\< Content-Length: 1090  
12:05:43,007 [ajp-nio-8009-exec-9] DEBUG org.apache.http.headers - http-outgoing-6 \<\< Date: Fri, 15 Dec 2017 04:05:42 GMT  
12:05:43,007 [ajp-nio-8009-exec-9] DEBUG org.apache.http.impl.execchain.MainClientExec - Connection can be kept alive indefinitely  
12:05:43,007 [ajp-nio-8009-exec-9] ERROR org.flowable.app.service.editor.AppDefinitionPublishService - Invalid deploy result code: HTTP/1.1 404 Not Found  
12:05:43,008 [ajp-nio-8009-exec-9] DEBUG org.apache.http.impl.conn.PoolingHttpClientConnectionManager - Connection manager is shutting down  
12:05:43,008 [ajp-nio-8009-exec-9] DEBUG org.apache.http.impl.conn.DefaultManagedHttpClientConnection - http-outgoing-6: Close connection  
12:05:43,008 [ajp-nio-8009-exec-9] DEBUG org.apache.http.impl.conn.PoolingHttpClientConnectionManager - Connection manager shut down  
12:05:43,009 [ajp-nio-8009-exec-9] DEBUG org.springframework.jdbc.datasource.DataSourceTransactionManager - Participating transaction failed - marking existing transaction as rollback-only  
12:05:43,009 [ajp-nio-8009-exec-9] DEBUG org.springframework.jdbc.datasource.DataSourceTransactionManager - Setting JDBC transaction [1367611661, URL=jdbc:oracle:thin:@10.1.8.166:1521:i9jzgz, UserName=IRMP, Oracle JDBC driver] rollback-only  
12:05:43,010 [ajp-nio-8009-exec-9] DEBUG org.mybatis.spring.SqlSessionUtils - Transaction synchronization deregistering SqlSession [org.apache.ibatis.session.defaults.DefaultSqlSession@2fd18616]  
12:05:43,010 [ajp-nio-8009-exec-9] DEBUG org.mybatis.spring.SqlSessionUtils - Transaction synchronization closing SqlSession [org.apache.ibatis.session.defaults.DefaultSqlSession@2fd18616]  
12:05:43,010 [ajp-nio-8009-exec-9] DEBUG org.springframework.jdbc.datasource.DataSourceTransactionManager - Initiating transaction rollback  
12:05:43,010 [ajp-nio-8009-exec-9] DEBUG org.springframework.jdbc.datasource.DataSourceTransactionManager - Rolling back JDBC transaction on Connection [1367611661, URL=jdbc:oracle:thin:@10.1.8.166:1521:i9jzgz, UserName=IRMP, Oracle JDBC driver]  
12:05:43,013 [ajp-nio-8009-exec-9] DEBUG org.springframework.jdbc.datasource.DataSourceTransactionManager - Releasing JDBC Connection [1367611661, URL=jdbc:oracle:thin:@10.1.8.166:1521:i9jzgz, UserName=IRMP, Oracle JDBC driver] after transaction  
12:05:43,013 [ajp-nio-8009-exec-9] DEBUG org.springframework.jdbc.datasource.DataSourceUtils - Returning JDBC Connection to DataSource  
12:05:43,016 [ajp-nio-8009-exec-9] DEBUG org.springframework.web.servlet.mvc.method.annotation.RequestResponseBodyMethodProcessor - Written [org.flowable.app.model.editor.AppDefinitionUpdateResultRepresentation@7eacb0a0] as “application/json” using [org.springframework.http.converter.json.MappingJackson2HttpMessageConverter@15388832]  
12:05:43,016 [ajp-nio-8009-exec-9] DEBUG org.springframework.web.servlet.DispatcherServlet - Null ModelAndView returned to DispatcherServlet with name ‘appDispatcher’: assuming HandlerAdapter completed request handling  
12:05:43,016 [ajp-nio-8009-exec-9] DEBUG org.springframework.web.servlet.DispatcherServlet - Successfully completed request  
12:05:43,016 [ajp-nio-8009-exec-9] DEBUG org.springframework.security.web.access.ExceptionTranslationFilter - Chain processed normally  
12:05:43,016 [ajp-nio-8009-exec-9] DEBUG org.springframework.security.web.context.SecurityContextPersistenceFilter - SecurityContextHolder now cleared, as request processing completed

---

<div class="post-metadata">

### Author: ![tijs](https://avatars.discourse-cdn.com/v4/letter/t/bc79bd/32.png) [@tijs](https://forum.flowable.org/u/tijs)
#### Post date: [December 15, 2017, 7:34am UTC](https://forum.flowable.org/t/still-get-error-if-use-non-default-port-and-ip/1335/4 "2017-12-15T07:34:57Z")

</div>

Hi,

You are using the Flowable Modeler app to deploy to the Flowable Task app?  
There’s a property in the flowable-ui-app.properties that you need to modify in this case.  
This is the default value:

deployment.api.url=http://localhost:8080/flowable-task/process-api

So you just have to modify it to the correct url for your servers.

Best regards,

Tijs

---

<div class="post-metadata">

### Author: ![johnny2002](https://avatars.discourse-cdn.com/v4/letter/j/65b543/32.png) [@johnny2002](https://forum.flowable.org/u/johnny2002)
#### Post date: [December 15, 2017, 7:36am UTC](https://forum.flowable.org/t/still-get-error-if-use-non-default-port-and-ip/1335/5 "2017-12-15T07:36:00Z")

</div>

> [@tijs](#):
>
> [http://localhost:8080/flowable-task/process-api](http://localhost:8080/flowable-task/process-api)

thanks, I already changed so

---

<div class="post-metadata">

### Author: ![johnny2002](https://avatars.discourse-cdn.com/v4/letter/j/65b543/32.png) [@johnny2002](https://forum.flowable.org/u/johnny2002)
#### Post date: [December 15, 2017, 1:21pm UTC](https://forum.flowable.org/t/still-get-error-if-use-non-default-port-and-ip/1335/6 "2017-12-15T13:21:12Z")

</div>

I guess I haven’t changed all flowable-ui-app.properties, will try at Monday.
