# Flowable upgrade from 6.5 to 6.6

**URL:** <https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369>\
**Category:** Flowable Engine\
**Created:** [January 21, 2021, 8:41am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369 "2021-01-21T08:41:49Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![Swapnil](https://avatars.discourse-cdn.com/v4/letter/s/ee7513/32.png) [@Swapnil](https://forum.flowable.org/u/Swapnil)\
**Post date:** [January 21, 2021, 8:41am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/1 "2021-01-21T08:41:49Z")

</div>

Hello Colleagues,

We are using flowable 6.4.2 currently. We want to move to 6.6 version

Therefore, we followed the staggered approach on our sandbox system to first upgrade it to 6.5 and then later from 6.5 to 6.6.

After performing an upgrade from version 6.5 to 6.6, we lost all the apps created in flowable. Do we need to export all the apps before upgrade and later import them? or there exists some other way of retaining the apps post upgrade.

Is this a normal behaviour? or did we miss some pre-requisite towards the upgrade?

Thanks,  
Swapnil

---

<div class="post-metadata">

**Author:** ![joram](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/joram/32/26_2.png) [@joram](https://forum.flowable.org/u/joram)\
**Post date:** [January 21, 2021, 8:45am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/2 "2021-01-21T08:45:10Z")

</div>

> [@Swapnil](#):
>
> Is this a normal behaviour?

No, of course not. This can only happen if you’ve been running with an in memory database that shuts down when the JDK is shut down.

---

<div class="post-metadata">

**Author:** ![Swapnil](https://avatars.discourse-cdn.com/v4/letter/s/ee7513/32.png) [@Swapnil](https://forum.flowable.org/u/Swapnil)\
**Post date:** [January 21, 2021, 8:49am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/3 "2021-01-21T08:49:10Z")

</div>

Hello Joram,

Thanks for the reply !

We’re using MySQL as a DB

---

<div class="post-metadata">

**Author:** ![joram](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/joram/32/26_2.png) [@joram](https://forum.flowable.org/u/joram)\
**Post date:** [January 21, 2021, 10:39am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/4 "2021-01-21T10:39:23Z")

</div>

If you have configured Flowable to use Mysql, the data should be in the database:

- Table ACT\_DE\_MODEL should contain any model (including apps)
- Table ACT\_APP\_DEPLOYMENT should contain apps that are deployed to the runtime

---

<div class="post-metadata">

**Author:** ![douglascrp](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/douglascrp/32/306_2.png) [@douglascrp](https://forum.flowable.org/u/douglascrp)\
**Post date:** [February 16, 2021, 12:40pm UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/5 "2021-02-16T12:40:01Z")

</div>

Hello.

I noticed something like that, but what I found out is that the applications and the processes definitions are not “lost”, they are just not shown in the modeler app.

I don’t know why, but I can see all the information when I use the admin, but not in the modeler.

---

<div class="post-metadata">

**Author:** ![Swapnil](https://avatars.discourse-cdn.com/v4/letter/s/ee7513/32.png) [@Swapnil](https://forum.flowable.org/u/Swapnil)\
**Post date:** [February 18, 2021, 6:45am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/6 "2021-02-18T06:45:48Z")

</div>

@joram

Hello  
Is this bug (post migration), which needs a correction? As we’re not able to see apps in modeler (though they’re not lost)

---

<div class="post-metadata">

**Author:** ![filiphr](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/filiphr/32/315_2.png) [@filiphr](https://forum.flowable.org/u/filiphr)\
**Post date:** [February 23, 2021, 6:59am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/7 "2021-02-23T06:59:54Z")

</div>

@douglascrp and @Swapnil are you sure that the application is pointing to the correct database?

How do you DB connection properties look like?

---

<div class="post-metadata">

**Author:** ![Swapnil](https://avatars.discourse-cdn.com/v4/letter/s/ee7513/32.png) [@Swapnil](https://forum.flowable.org/u/Swapnil)\
**Post date:** [February 23, 2021, 7:02am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/8 "2021-02-23T07:02:22Z")

</div>

@filiphr

Yes, the application was pointing to wrong database. We’ve corrected it now and the flowable works fine.

Thanks

---

<div class="post-metadata">

**Author:** ![Swapnil](https://avatars.discourse-cdn.com/v4/letter/s/ee7513/32.png) [@Swapnil](https://forum.flowable.org/u/Swapnil)\
**Post date:** [February 23, 2021, 8:14am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/9 "2021-02-23T08:14:15Z")

</div>

@filiphr

Post upgrade to 6.6 we’re facing issues with Admin

“An error occurred while calling flowable HTTP/1.1 401”

2021-02-23 09:12:58.302 ERROR 23165 — [io2-443-exec-40] o.f.u.a.r.c.DeploymentsClientResource : Error getting deployments

org.flowable.ui.admin.service.engine.exception.FlowableServiceException: An error occurred while calling Flowable: HTTP/1.1 401  
at org.flowable.ui.admin.service.engine.FlowableClientService.executeRequest(FlowableClientService.java:167) ~[flowable-ui-admin-logic-6.6.0.jar:6.6.0]  
at org.flowable.ui.admin.service.engine.FlowableClientService.executeRequest(FlowableClientService.java:135) ~[flowable-ui-admin-logic-6.6.0.jar:6.6.0]  
at org.flowable.ui.admin.service.engine.FlowableClientService.executeRequest(FlowableClientService.java:131) ~[flowable-ui-admin-logic-6.6.0.jar:6.6.0]  
at org.flowable.ui.admin.service.engine.DeploymentService.listDeployments(DeploymentService.java:75) ~[flowable-ui-admin-logic-6.6.0.jar:6.6.0]  
at org.flowable.ui.admin.rest.client.DeploymentsClientResource.listDeployments(DeploymentsClientResource.java:60) ~[flowable-ui-admin-rest-6.6.0.jar:6.6.0]  
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:na]  
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64) ~[na:na]  
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:na]  
at java.base/java.lang.reflect.Method.invoke(Method.java:564) ~[na:na]  
at org.springframework.web.method.support.InvocableHandlerMethod.doInvoke(InvocableHandlerMethod.java:190) ~[spring-web-5.2.9.RELEASE.jar:5.2.9.RELEASE]  
at org.springframework.web.method.support.InvocableHandlerMethod.invokeForRequest(InvocableHandlerMethod.java:138) ~[spring-web-5.2.9.RELEASE.jar:5.2.9.RELEASE]  
at org.springframework.web.servlet.mvc.method.annotation.ServletInvocableHandlerMethod.invokeAndHandle(ServletInvocableHandlerMethod.java:105) ~[spring-webmvc-5.2.9.RELEASE.jar:5.2.

---

<div class="post-metadata">

**Author:** ![filiphr](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/filiphr/32/315_2.png) [@filiphr](https://forum.flowable.org/u/filiphr)\
**Post date:** [February 23, 2021, 8:15am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/10 "2021-02-23T08:15:50Z")

</div>

@Swapnil this looks like a misconfiguration as well. You are getting HTTP 401, which means that the user you are using in Admin does not have access to the application.

---

<div class="post-metadata">

**Author:** ![Swapnil](https://avatars.discourse-cdn.com/v4/letter/s/ee7513/32.png) [@Swapnil](https://forum.flowable.org/u/Swapnil)\
**Post date:** [February 23, 2021, 8:20am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/11 "2021-02-23T08:20:12Z")

</div>

@filiphr

The User I’m using have access to all apps Admin/Task/Modeler/IDM. Could it be any other issue?

---

<div class="post-metadata">

**Author:** ![Swapnil](https://avatars.discourse-cdn.com/v4/letter/s/ee7513/32.png) [@Swapnil](https://forum.flowable.org/u/Swapnil)\
**Post date:** [February 23, 2021, 9:26am UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/12 "2021-02-23T09:26:26Z")

</div>

@filiphr

Thanks !! The error with Admin was solved after changing credentials for the user.

Now we’re facing errors while executing models:-

2021-02-23 10:21:19.983 ERROR 23165 — [io2-443-exec-53] o.s.b.w.servlet.support.ErrorPageFilter : Forwarding to error page from request [/app/rest/process-instances/] due to exception [

### Error updating database. Cause: java.sql.SQLSyntaxErrorException: Unknown column ‘TRANSACTION\_ORDER\_’ in ‘field list’

### The error may exist in org/flowable/db/mapping/entity/HistoricActivityInstance.xml

### The error may involve org.flowable.engine.impl.persistence.entity.HistoricActivityInstanceEntityImpl.bulkInsertHistoricActivityInstance-Inline

### The error occurred while setting parameters

### SQL: insert into ACT\_HI\_ACTINST ( ID\_, REV\_, PROC\_DEF\_ID\_, PROC\_INST\_ID\_, EXECUTION\_ID\_, ACT\_ID\_, TASK\_ID\_, CALL\_PROC\_INST\_ID\_, ACT\_NAME\_, ACT\_TYPE\_, ASSIGNEE\_, START\_TIME\_, END\_TIME\_, TRANSACTION\_ORDER\_, DURATION\_, DELETE\_REASON\_, TENANT\_ID\_ ) values (?, 1, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) , (?, 1, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)

### Cause: java.sql.SQLSyntaxErrorException: Unknown column ‘TRANSACTION\_ORDER\_’ in ‘field list’]

org.apache.ibatis.exceptions.PersistenceException:

### Error updating database. Cause: java.sql.SQLSyntaxErrorException: Unknown column ‘TRANSACTION\_ORDER\_’ in ‘field list’

### The error may exist in org/flowable/db/mapping/entity/HistoricActivityInstance.xml

### The error may involve org.flowable.engine.impl.persistence.entity.HistoricActivityInstanceEntityImpl.bulkInsertHistoricActivityInstance-Inline

### The error occurred while setting parameters

### SQL: insert into ACT\_HI\_ACTINST ( ID\_, REV\_, PROC\_DEF\_ID\_, PROC\_INST\_ID\_, EXECUTION\_ID\_, ACT\_ID\_, TASK\_ID\_, CALL\_PROC\_INST\_ID\_, ACT\_NAME\_, ACT\_TYPE\_, ASSIGNEE\_, START\_TIME\_, END\_TIME\_, TRANSACTION\_ORDER\_, DURATION\_, DELETE\_REASON\_, TENANT\_ID\_ ) values (?, 1, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) , (?, 1, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)

### Cause: java.sql.SQLSyntaxErrorException: Unknown column ‘TRANSACTION\_ORDER\_’ in ‘field list’

```
    at org.apache.ibatis.exceptions.ExceptionFactory.wrapException(ExceptionFactory.java:30) ~[mybatis-3.5.5.jar:3.5.5]
    at org.apache.ibatis.session.defaults.DefaultSqlSession.update(DefaultSqlSession.java:199) ~[mybatis-3.5.5.jar:3.5.5]
    at org.apache.ibatis.session.defaults.DefaultSqlSession.insert(DefaultSqlSession.java:184) ~[mybatis-3.5.5.jar:3.5.5]
```

---

<div class="post-metadata">

**Author:** ![douglascrp](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/douglascrp/32/306_2.png) [@douglascrp](https://forum.flowable.org/u/douglascrp)\
**Post date:** [February 26, 2021, 1:46pm UTC](https://forum.flowable.org/t/flowable-upgrade-from-6-5-to-6-6/7369/13 "2021-02-26T13:46:41Z")

</div>

Hello, and sorry for the late response.

Well, I guess everything is right, as the environment is the same, and only the war files got replaced.  
Besides that, I can see the historical data, and the already running process were still there, so I believe there is nothing wrong with the connection settings.

The only database related properties I have in place are:

```
spring.datasource.driver-class-name=org.postgresql.Driver
spring.datasource.url=jdbc:postgresql://localhost:5432/flowable
spring.datasource.username=flowable
spring.datasource.password=flowable
```
