# Changing password causes failure

**URL:** <https://forum.flowable.org/t/changing-password-causes-failure/1282>\
**Category:** Flowable Engine\
**Created:** [December 1, 2017, 12:02am UTC](https://forum.flowable.org/t/changing-password-causes-failure/1282 "2017-12-01T00:02:59Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![rob](https://avatars.discourse-cdn.com/v4/letter/r/838e76/32.png) [@rob](https://forum.flowable.org/u/rob)\
**Post date:** [December 1, 2017, 12:02am UTC](https://forum.flowable.org/t/changing-password-causes-failure/1282/1 "2017-12-01T00:02:59Z")

</div>

Hi all,  
When I change the passwords for the default users (admin, fozzie, etc) from the base install, it causes problems.

When I change the admin password, I can login to the idm app fine. However, trying to use any other app results in a redirect to the following url and the page shows the login prompt. If I try to login at that admin prompt, it refreshes back to the same page with empty fields for user/pw.

Example when trying to access the admin app:  
[http://flowable.myurl.com:8080/flowable-idm/#/login?redirectOnAuthSuccess=true&redirectUrl=http:%2F%2F/flowable.myurl.com:8080%2Fflowable-admin%2F](http://flowable.myurl.com:8080/flowable-idm/#/login?redirectOnAuthSuccess=true&redirectUrl=http:%2F%2F/flowable.myurl.com:8080%2Fflowable-admin%2F)

When I change the passwords for the other users (fozzie, etc), I can’t get into any app as I get an “invalid credentials” notification.

When I look inside the database (postgresql), I can see that the passwords have changed in the act\_id\_user table, and that they match the passwords I’m trying to use.

When I change the passwords back to any of the user’s original passwords, I can access all apps fine.

My db user has full privileges for all flowable tables, and execute and usage privilege on the schema.

My docker compose file (doesn’t use docker-compose formatting standards, it’s for a kubernetes based system)  
ports:  
-8080:8080  
-9977:9977  
env\_vars:  
datasource.driver: org.postgresql.Driver  
datasource.url: jdbc:postgresql://postgresql.host.local:5432/sys\_bpm  
datasource.username: myuser  
datasource.password: 1234  
idm.app.url: [http://flowable.host.local:8080/flowable-idm](http://flowable.host.local:8080/flowable-idm)  
idm.app.redirect.url: [http://flowable.myurl.com:8080/flowable-idm](http://flowable.myurl.com:8080/flowable-idm)  
rest.process.app.host: [http://flowable.host.local](http://flowable.host.local)  
rest.process.app.port: 9977  
rest.dmn.app.host: [http://flowable.host.local](http://flowable.host.local)  
rest.dmn.app.port: 9977  
rest.form.app.host: [http://flowable.host.local](http://flowable.host.local)  
rest.form.app.port: 9977  
rest.content.app.host: [http://flowable.host.local](http://flowable.host.local)  
rest.content.app.port: 9977

Any ideas about how to fix this?

---

<div class="post-metadata">

**Author:** ![martin.grofcik](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.flowable.org/martin.grofcik/32/71_2.png) [@martin.grofcik](https://forum.flowable.org/u/martin.grofcik)\
**Post date:** [December 1, 2017, 7:32am UTC](https://forum.flowable.org/t/changing-password-causes-failure/1282/2 "2017-12-01T07:32:35Z")

</div>

Hi Rob,

Did you also change

```
rest.*.app.user=admin
rest.*.app.password=test

```

in all flowable-ui-app.properties files?

Martin

---

<div class="post-metadata">

**Author:** ![rob](https://avatars.discourse-cdn.com/v4/letter/r/838e76/32.png) [@rob](https://forum.flowable.org/u/rob)\
**Post date:** [December 1, 2017, 6:59pm UTC](https://forum.flowable.org/t/changing-password-causes-failure/1282/3 "2017-12-01T18:59:55Z")

</div>

Hi Martin,

Thanks. So I added those properties, along with idm.admin.user and idm.admin.password to my system environment variables (which according to what I see on my flowable admin dashboard it overrides those settings within the flowable-ui-app.properties files inside each app folder). Now the admin is working with the new password successfully.

However, all other users still have the same problem, including the default users, and any new users I create. I can see the users in the database, but can’t login to the task app. Am I wrong about the environment variables overriding the flowable-ui-app.properties file, or is there something else I can change? I tried moving to a mysql database and had the same problem.

---

<div class="post-metadata">

**Author:** ![rob](https://avatars.discourse-cdn.com/v4/letter/r/838e76/32.png) [@rob](https://forum.flowable.org/u/rob)\
**Post date:** [December 5, 2017, 11:36pm UTC](https://forum.flowable.org/t/changing-password-causes-failure/1282/4 "2017-12-05T23:36:40Z")

</div>

I resolved the problem with the non-admin users by giving them proper permissions inside the IDM app.
